Front end vibration - Dodge Avenger Forum : Dodge Avenger Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-26-2011, 11:09 PM Thread Starter
Junior Member
 
Join Date: Nov 2011
Posts: 1
Front end vibration

I have a 1999 Dodge avenger all the joints have been replaced besides the passenger side tie rod. i have new tires on the front. At high speeds the front end has a bad vibration. Could it just need a front end alingment?
Jdracing4ma is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-04-2011, 09:45 PM
Junior Member
 
Join Date: Dec 2011
Posts: 4
check your breaking habits. my front rotors are a weak spot and can get quite shakey when warm...
coldrold is offline  
post #3 of 3 (permalink) Old 01-05-2012, 07:04 PM
Junior Member
 
Join Date: Dec 2011
Posts: 3
How many miles on the vehicle? Could be a bent rim...struts that have lost gas charge...poorly balanced tires...worn suspension components??? I am assuming that this shake is the cause of the stated repairs you had done but I have to ask was the shake there before the repairs? If so check for a bent wheel...be sure to check the inner and outer tie rod ends as they are common to go bad as are the lower control arms/ball joints. More info would help on the speed the shimmy is felt...does the steering wheel move in accordance with the shake...mileage of car...etc
winterfunguy is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome